Users may experience issues when creating, updating och cancelling calendar items in Outlook Desktop Client.
Incident Report for Midpoint AB
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 10:47 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2024 - 09:45 CEST
Identified
Users may experience issues when creating, updating och cancelling calendar items in Outlook Desktop Client. A workaround is to visit the Outlook Web App and perform the same action there: https://outlook.office.com/calendar

Microsoft is investigating this issue and is expecting a solution by the end of Friday (2024-07-05)

Microsoft has released an update that went live today (2024-07-12) that is supposed to fix the issue
Microsoft is now monitoring the issue and will update the incident tomorrow with more information
Posted Jul 04, 2024 - 14:38 CEST
This incident affected: Office 365.