Telefonistörning
Incident Report for Midpoint AB
Resolved
This incident has been resolved.
Posted May 16, 2024 - 11:31 CEST
Identified
För tillfället kan man inte ringa in till oss.
Vänligen skicka ett email med ert telefonnummer så ringer vi upp er.

Vi nås på E-post:
- support@midpoint.se
- sales@midpoint.se
Posted May 16, 2024 - 08:16 CEST
This incident affected: Telefoni.